Top Posts

best inline fan for grow tent what are good cpu temps display driver amd stopped responding and has recovered pcie 8 pin power connector how to profit from bitcoin mining write your own bitcoin miner sapphire vapour x r9 280x 75w 6 pin pci express power connector asic miner block erupter usb 4 pin molex to 6 pin 6 pin sata power cable 6 pin to molex adapter power supply for r9 290 is jacque fresco still alive amd driver stopped responding successfully recovered what are good cpu temps atikmdag.sys blue screen windows 7 power supply bronze silver gold platinum molex to 6 pin pci-e p vs np for dummies is jacque fresco still alive how to update amd bios molex to 6 pin pci-e mass effect 2 security nodes pci express slots on motherboard what does lepa mean in spanish gigabyte ga 990fxa ud3 rev 1.1 single molex to 6 pin failed to locate cl exe bitcoin mining rate of return amd overdrive fan control not working

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Gigabyte 990FXA-UD3 Rev 4.0

golekiprogolekipro Member Posts: 6
Hi Everyone,
I have a rig running this motherboard, this board has 6 PCIe slots ( 2 16x, 2 4x, 2 1x), I can get 5 cards to work on this board under Linux. The 6th card does not work at all, in Linux logs, I see things like "Card Fell off the bus". I know it is funny :). But basically it means that the BIOS see's 6th Card, but OS can't use it when it tries to load drivers. As soon as I take that card off, system boots up fine and I can mine on 5 cards.

Has anyone else see this problem before with this version of the motherboard (rev 4.0)?

In BIOS I have enabled IOMMU and disabled unwanted stuff like 1394 ports and audio controller. I have also already tried Presence Detection jumping of port. It works for now with 5 cards and is stable, but I am wasted 25MH not able to squeeze more out of this card. Any help is appreciated. Thank you.


  • ecs87ecs87 Dekalb, ILMember Posts: 335 ✭✭✭
    I have the exact same board...ROYAL PAIN to get 6 cards working...until I swapped PSUs. New PSU led to no more BIOS hangs and Win10 instantly recognized all my 500 series cards (sry haven't used Linux for mining).
  • golekiprogolekipro Member Posts: 6
    That is interesting, my system is powered by 2 650 Watt PSU's. So I am pretty sure that power is not an issue. Having said that, one of my cards is an EVGA card that needs 2 8 pin power leads. You raise an interesting point, may be I need to balance the cards a bit across the 2 power supplies. I will try that tomorrow morning and report back.
  • curtisimocurtisimo Member Posts: 10
    I'm having a hell of a time getting 5 RX 480 cards to work on this mobo with Windows 10. The rig works flawlessly with ethOS but I was hoping to get a little more efficiency with Windows. When I finally got the system to log in with all 5 cards attached, Claymore and genoli both didnt detect any gpus. I just put the ethOS drive back in for now.
  • ecs87ecs87 Dekalb, ILMember Posts: 335 ✭✭✭
    edited June 25
    Fwiw I used 17.5.2 for the driver. The earlier one (I think 17.4.3) was nothing but headaches. The drivers needed to be patched afterwards but 6 cards are definitely possible on this board, it's just very picky.
  • golekiprogolekipro Member Posts: 6
    Ok I have tried various combinations, but nothing seems to work. I have narrowed it down to PCIE 1x Port 1. If the Riser is plugged into that port, I always get a crash in Kernel and root cause is nvidia driver. I think I have to try a various Kernel and driver combinations to really get to bottom of this, but it seems to me that the port might be faulty.

    BTW guys I forgot to mention I am using GTX cards so can't use ethOS to test.
  • curtisimocurtisimo Member Posts: 10
    I tried again this morning. Used DDU to remove all drivers then installed 17.5.2, patched and then tested with one card. Windows logs in and mines perfectly with one card. Once I plug in a second card, Windows freezes during login (the swirling dots eventually freeze up after I enter my password). I tried different PCIe ports and card combinations. No luck
or to comment.