How to tell ethminer which GPU to use

thomaskadethomaskade Member Posts: 2
edited August 2015 in Mining
Hi,

I have an onboard GPU and a GeForce GTX card in my system. This is how I start the miner:

ethminer.exe -G -t 1 -F "http://lcalhost:8545" Found suitable OpenCL device [Intel(R) HD Graphics 4600] with 1494849946 bytes f GPU memory

But no matter how I choose -t (I've tried 0, 1, 2 and even 3),
it always chooses the Intel onbard chip as GPU. So how do I tell ethminer to use my GTX card?

Comments

  • thomaskadethomaskade Member Posts: 2
    I forgot to mention, in hardware settings, the onbard GPU is "Device 2" and the GTX card is "Device 0".
    I also tried to start the miner with

    ethminer -G --opencl-device 0

    But here also, no matter what I use as --opencl-device (0,1,2,3) always the onboard chip is used.
  • Marvell9Marvell9 Member Posts: 593 ✭✭✭
    just disable your intel HD graphics reboot .. volia lol
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    Also make sure you don't have the wrong OpenCL platform (Intel's) chosen. You can change that with --opencl--platform 1
  • TStewartTStewart Member Posts: 2
    Genoil said:

    Also make sure you don't have the wrong OpenCL platform (Intel's) chosen. You can change that with --opencl--platform 1

    I had the exact same problem. Genoils suggestion fixed it!
    I used: ethminer -G -M --opencl-device 0 --opencl-platform 1
  • serverleaderserverleader Member Posts: 1
    TStewart said:

    Genoil said:

    Also make sure you don't have the wrong OpenCL platform (Intel's) chosen. You can change that with --opencl--platform 1

    I had the exact same problem. Genoils suggestion fixed it!
    I used: ethminer -G -M --opencl-device 0 --opencl-platform 1
    thanks this worked for me.
or to comment.