Problem with risers(?)

ZanderMZanderM Member Posts: 86
edited August 2016 in Mining
Hi, I'm trying to setup a few rigs, but I'm having a big problem..

I've been going at this for 10 hours straight now, can't seem to figure out what the problem is.

When i connect a gpu(RX 470) with a 1x16 usb riser, the drivers just crashes, sometimes I get a bluescreen, sometimes not.
I've never been able to mine though.

Mobo: asrock h1 btc
gpu: xfx 470 4gb single fan

I've tried 3 mobos, 4-5 gpus, 3-4 risers, all h81's and rx 470's (all new and never used ones).
Edit: Also tried different psu's

I've also tried using one of the gpu's and risers on a different mobo (ASUS Z97-A), and It worked just fine.

So it seems to be a problem or specific step that I've missed while using risers with h1 btc.

I've done a fresh install of windows 4 times, still no luck.

I really need some help :(
«13

Comments

  • ethfanethfan Member Posts: 458 ✭✭✭
    Have you tried direct connection to the mobo without using a riser? If that works, you know it is the riser that is the issue.
  • ZanderMZanderM Member Posts: 86
    ethfan said:

    Have you tried direct connection to the mobo without using a riser? If that works, you know it is the riser that is the issue.

    Forgot to mention that, yes, without the riser, it works perfectly fine.
  • ulfbertulfbert Member Posts: 64
    edited August 2016
    Just some things I'm throwing out, sorry if it sounds simplistic.

    1) Check you BIOS settings. In a peripherals section, there will be the designated output for your monitor. Make sure you're in the right slot.

    2) This is just me, but start your rig with only one GPU. It sounds like you are, just checking....I prefer to see that I can get the software working correctly for one first and see that it mines. If there is to much going on in the beginning, it's harder to trace.

    3) Is your iommu setting in the BIOS enabled or disabled? Don't refer to the manual ..actually check. What is it set too?

    4) What version of Windows?

    5) You say adding a card and it crashes. Are you adding the card after you start your rig?
    Post edited by ulfbert on
  • ethfanethfan Member Posts: 458 ✭✭✭
    ZanderM said:


    Forgot to mention that, yes, without the riser, it works perfectly fine.

    That means the riser. Ribbon or usb? If ribbon, does it have power connector? Try a different riser. I recently bought a batch of 8 usb risers and NONE worked!
  • ZanderMZanderM Member Posts: 86
    ethfan said:

    ZanderM said:


    Forgot to mention that, yes, without the riser, it works perfectly fine.

    That means the riser. Ribbon or usb? If ribbon, does it have power connector? Try a different riser. I recently bought a batch of 8 usb risers and NONE worked!
    The risers work on another mobo
  • ZanderMZanderM Member Posts: 86
    edited August 2016
    ulfbert said:

    Just some things I'm throwing out, sorry if it sounds simplistic.

    1) Check you BIOS settings. In a peripherals section, there will be the designated output for your monitor. Make sure your in the right slot.

    2) This is just me, but start your rig with only one GPU. It sounds like you are, just checking....I prefer to see that I can get the software working correctly for one first and see that it mines. If there is to much going on in the beginning, it's harder to trace.

    3) Is your iommu setting in the BIOS enabled or disabled? Don't refer to the manual ..actually check. What is it set too?

    4) What version of Windows?

    5) You say adding a card and it crashes. Are you adding the card after you start your rig?

    I'll check 1 and 3 tomorrow when i wake up.

    everything works fine with 1 gpu

    I'm using windows 10, adding card before I am starting the rig.
  • ZanderMZanderM Member Posts: 86
    This is what any card connected with a riser looks like in gpuz

  • ZanderMZanderM Member Posts: 86
    Device manager:


    qwe.png 37.5K
  • ZanderMZanderM Member Posts: 86
    As for the bios, I cant seem to find iommu settings
  • ZanderMZanderM Member Posts: 86
  • ulfbertulfbert Member Posts: 64
    I'm rather sure you won't be able to access your iommu setting in the Windows device manager. Is this how your trying to access the setting? You'll have to reboot your computer. You will see a start up window asking you if you want to enter the BIOS and hit the designated key is tells you too. It should be the DEL key. You will then enter the BIOS. The iommu setting should be in peripherals. See if it's on. Let me know how you make out.

    What driver are you using?

    What is error code 43?
  • ZanderMZanderM Member Posts: 86
    ulfbert said:

    I'm rather sure you won't be able to access your iommu setting in the Windows device manager. Is this how your trying to access the setting? You'll have to reboot your computer. You will see a start up window asking you if you want to enter the BIOS and hit the designated key is tells you too. It should be the DEL key. You will then enter the BIOS. The iommu setting should be in peripherals. See if it's on. Let me know how you make out.

    What driver are you using?

    What is error code 43?

    Man, I'm not that of a noob. I know how to access the bios and use it. I'm saying, I can't see the iommu setting.

    I just added pic of device manager and gpuz for extra info.

    Bios is set to use pci-e not igpu, I've never heard of iommu though, and I don't believe that the setting have such an effect that I get constant crashes when trying to mine
  • ulfbertulfbert Member Posts: 64
    Lol.... Not trying to imply noob status. I just saw your pics and then your question. just making sure.

    How about a VT-d setting? .

    http://us.informatiweb.net/tutorials/it/9-bios/215--enable-iommu-or-vt-d-in-your-motherboard-bios.html

    This setting is one of those "little things" that can make the difference. It did for me on 2 rigs. I'm using AMD chipset though. Worst case, it doesn't help.
  • newmznewmz AustraliaMember Posts: 299 ✭✭✭
    I would really strongly recommend you try EthOS or if you know Linux well enough, build your own for mining. I had about 2 weeks of headaches when I started with Windows (tried 7 and 10). Then I bought a copy of EthOS and it just worked and has been solid and stable for many months now. I might sound like I'm trying to sell it but I'm not, I just often recommend it because I never have to worry about any of the BS that I constantly read in these forums from people using Windows.

    I know there is a LOT of info out there about using Windows because so many people use it and everyone is used to it, but I think there is actually too much info and you get contradictory advice. It's great for it's diversity of uses but when you want your machine to do one thing and do it really well - get something built for purpose.
  • ZanderMZanderM Member Posts: 86
    @ulfbert VT-d capability unsupported
  • ulfbertulfbert Member Posts: 64
    ZanderM,

    We know your board works...you can use it with the card plugged in. There are molex connectors on the board are they being powered?

    Your card works, as it runs in the slot without the USB riser.

    Your riser works as you have tested on a different model board.

    So its either a config issue or a driver issue. Hmmm. Check your exact version of windows through the threads. Even minor changes to Windows versions seems to cause issues from what I have seen. Latest video driver from XFX ?

    If that doesn't work, you may want to try @newmz suggestion and get ethOS or download and reformat your SSD with Ubuntu server, install LXDE GUI (it helps with some tasks), and build from the repositories.
  • ZanderMZanderM Member Posts: 86
    @ulfbert @newmz So I bought ethOS, but getting this error: WRONG DRIVER! ADD "driver [worker] amdgpu" TO CONFIG

    The thing is, I have done that, still getting the same error
  • ulfbertulfbert Member Posts: 64
    edited August 2016
    Look in your local.conf file. It is in your home/ethos folder. Do you see a line for globaldriver ? You need to change that configuration setting to amdgpu.

    Please copy your local.conf file to local.conf.bak or something similar before making changes. cp local.conf local.conf.bak This way if you make a serious error your covered

    to simply look at the file it's type : cat local.conf
    to modify it's: sudo nano local.conf

    make sure you save you changes before exiting. Control + o, then return, then control + x to exit


  • zawawazawawa Member Posts: 27
    I had a similar connectivity issue with my USB PCIe riser. Squeezing the metal pieces of the cable and plug for a better contact did the trick for me. This is a hardware issue, so ethOS wouldn't help.
  • ZanderMZanderM Member Posts: 86
    ulfbert said:

    Look in your local.conf file. It is in your home/ethos folder. Do you see a line for globaldriver ? You need to change that configuration setting to amdgpu.

    Please copy your local.conf file to local.conf.bak or something similar before making changes. cp local.conf local.conf.bak This way if you make a serious error your covered

    to simply look at the file it's type : cat local.conf
    to modify it's: sudo nano local.conf

    make sure you save you changes before exiting. Control + o, then return, then control + x to exit

    I had already done that, but for some reason after a couple of reboots it worked.

    But it's still something seriously wrong, when i started mining, one card had 20 mh/s and the other 6mh/s.

    I rebooted, and I can now only mine with one card, even thogh it detects the other card.
    zawawa said:

    I had a similar connectivity issue with my USB PCIe riser. Squeezing the metal pieces of the cable and plug for a better contact did the trick for me. This is a hardware issue, so ethOS wouldn't help.

    What metal pieces? Could you be more exact? :D
  • ulfbertulfbert Member Posts: 64
    One more note. Make sure the # sign is removed from in front of globaldriver too..
  • ZanderMZanderM Member Posts: 86
    ulfbert said:

    One more note. Make sure the # sign is removed from in front of globaldriver too..

    That's no longer a problem. The problem now is that it only mines on one card
  • ulfbertulfbert Member Posts: 64
    http://ethosdistro.com/kb/#single-rig

    make sure you follow there instructions for provisioning an Intel board.

    Also, there is a GUI. At the bottom there is a yellow/orange icon which kinda looks like a flower. It's the IRC channel and you can get chat help.

    When the rig first starts it takes a few for all the miners to report to the output screen. Also there a special instructions for configuring a 400 series rig in the conf instructions
  • zawawazawawa Member Posts: 27
    ZanderM said:

    ulfbert said:

    Look in your local.conf file. It is in your home/ethos folder. Do you see a line for globaldriver ? You need to change that configuration setting to amdgpu.

    Please copy your local.conf file to local.conf.bak or something similar before making changes. cp local.conf local.conf.bak This way if you make a serious error your covered

    to simply look at the file it's type : cat local.conf
    to modify it's: sudo nano local.conf

    make sure you save you changes before exiting. Control + o, then return, then control + x to exit

    I had already done that, but for some reason after a couple of reboots it worked.

    But it's still something seriously wrong, when i started mining, one card had 20 mh/s and the other 6mh/s.

    I rebooted, and I can now only mine with one card, even thogh it detects the other card.
    zawawa said:

    I had a similar connectivity issue with my USB PCIe riser. Squeezing the metal pieces of the cable and plug for a better contact did the trick for me. This is a hardware issue, so ethOS wouldn't help.

    What metal pieces? Could you be more exact? :D
    You know, the rectangular-shaped ones for USB ground:
    http://pinouts.ru/visual/USB.jpg
    Make sure that these pieces have a good contact. Don't squeeze them too hard, though!
  • ZanderMZanderM Member Posts: 86
    0 mhs on second card
  • ulfbertulfbert Member Posts: 64
    edited August 2016
    1) You might have to play with the slots. Are you on the 2 closest to the CPU ? Take whichever one is not designated as your primary in the BIOS and move it. You may have to do it a few times. These slots share resources and sometimes the order makes a difference.

    2) If you can't still get it, try it with a riser you know works. Move the one GPU that is working over into another slot and the one you don't see mining into the primary. Is that one working now?
  • ZanderMZanderM Member Posts: 86
    ulfbert said:

    1) You might have to play with the slots. Are you on the 2 closest to the CPU ? Take whichever one is not designated as your primary in the BIOS and move it. You may have to do it a few times. These slots share resources and sometimes the order makes a difference.

    2) If you can't still get it, try it with a riser you know works. Move the one GPU that is working over into another slot and the one you don't see mining into the primary. Is that one working now?

    I can't see the screen on any x1 pcie slots with working riser and gpu
  • ulfbertulfbert Member Posts: 64
    What slot is your default video slot according in your BIOS ? Your video output for your monitor will usually only work on that PCIe slot, especially after the driver is installed. For my boards it's the first 16 slot closest to the CPU. Just plug in only one GPU to that slot, I think there is only one 16 slot on your model and see what you get. Lets not worry about the 2nd GPU for now.
or to comment.